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GENERAL
What web browsers and versions does BlueMind support?
BlueMind supports the following web browsers:
Firefox from version ESR 17
Chrome from version 24
Internet Explorer from version 8 (except the admin console)
Safari from version 6
To find out more about compatibility with web browsers, devices and thick clients, please refer to the page Compatibility.

What characters are allowed in passwords?
Passwords can include upper and lower case letters, numbers and special characters. Accented characters may not be used.
ASCII characters can be used, excluding control characters.

How does offline mode work?
What is offline mode?

Offline mode allows you to continue working with BlueMind when your internet connection is lost either voluntarily (using your internet browser's offline mode if
allowed or by disconnecting your computer's internet connection) or involuntarily (network disruption, cable unplugged, etc.). New inputs (new contacts, appointments,
meeting acceptances, etc.) are saved in the browser and when you are connected again, the data is synchronized with the server and saved in BlueMind.

What applications are supported in offline mode?
Currently, the Contacts, Calendar and Tasks applications are supported.

How do I enable offline mode?
Offline mode is enabled automatically when your browser's internet connection is lost (whether voluntarily or not).
When you're offline, your navigation bar's personal menu is grayed out, and when you open it, it reads "Offline" and its links are disabled:

What web browsers are compatible?
Offline mode is available in Firefox, Chrome and Safari.
Offline mode being reliant on the browser's data storage capacity, some browsers or browser versions do not support his technology (Firefox in Private Mode, Internet
Explorer, Edge).

MAIL
How can I make BlueMind to my default "mailto:" provider?
"mailto:" links allow you to open your default mail software composer.
To get the BlueMind composer to open when you click a mailto: link, in a web page or an email for example:
go to BlueMind's advanced settings: in user preferences > Mail section > "Email client advanced settings" link
in the first section, "User Interface", click the link "Register protocol handler for mailto: links"
confirm authorization when prompted by the browser
To find out more, please go to the page on Advanced settings.

Unread messages in my sub-folders are only shown when I view
said sub-folder
To change this behavior and force BlueMind to retrieve messages from all folders and sub-folders every time it queries the server:
go to BlueMind's advanced settings: in user preferences > Mail section > " Email client advanced settings" link
in the section "Mailbox view" check the box "Check all folders for new messages"
To find out more, please go to the page on Advanced settings.

I'd rather reply BELOW the original message
When you write a message, the original message is quoted underneath by default. To change this and place the original message above the message with your reply below:
go to BlueMind's advanced settings: in user preferences > Mail section > "Email client advanced settings" link

in the section "Composing messages", then "Main options", select your choice from the list "When replying":
start new message above original
start new message below original
To find out more, please go to the page on Advanced settings.

Edit as new message
This option allows you to open a message in the composer, without being shown as a reply or forwarded.
To do this, you have two options:

1. right-click the message in the list > "More actions" > "Edit as new"
2. select the message in the list and click the menu "More actions" above the message list "Edit as new"

I'd like to use different signatures depending on the recipient
To do this you must create several "Identities" and set up a signature for each. When you send a message, all you will need to do is select the identity you want from the
sender box and the corresponding signature will be added.
Identities also allow you to customize the display name as well as the email alias used.
To find out more, go to the page on Identities.

I have reached my mailbox quota but I can't delete messages to
reduce its size
This is because when you delete a message using the "delete" button or the "Del" key, it is moved to the trash, and to do this it needs to be copied in a temporary directory.
This operation is therefore impossible if the space quota has been reached.
To free up space in a mailbox whose size quota has been reached, you must delete files directly: select the message(s) you want to delete and type "Shift-Del". You should
then be prompted to confirm deletion.
To find out more, go to the page on Mail.

I can't see the priority status of incoming messages
The Mail application incorporates a message priority status column, but it is not shown by default. To display this column:
Click the "List options" gears button at the top right of the message list
Check the "Priority" box in the column list
Click "Save" to confirm.
Note: The column is added and placed in last position.
To find out more about organizing columns, go the page on Mail > chapter 4.1 - Columns and sorting.

My shared mailboxes are not shown in the folders list
In some cases, when a user is given privileges on a shared mailbox, the mailbox is not shown in their folders list. This is due to a bug in the webmail's engine display
(Roundcube).
To show these folders, simply display the folders' list action menu:

Having the menu shown on screen should be enough to make the mailbox appear in the list, no further action is required.

INSTANT MESSAGING
I can't see the instant messaging icon in BlueMind
This means that instant messaging hasn't been enabled on your domain, or the administrator has chosen to restrict this service to certain users only.
Contact your administrator or, if you're an administrator, go to the domain management documentation for information on enabling instant messaging.

I don't know how to clear my conversations history
This is because this feature isn't available in BlueMind's instant messaging application yet.

I get an SSL error when I try to connect to the XMPP server with
Thunderbird
This is because since version 38.0, Thunderbird uses DHE keys.

Manual fix

In Thunderbird Preferences > Advanced > Config Editor, set the following settings to 'true':
security.ssl3.dhe_rsa_aes_128_sha
security.ssl3.dhe_rsa_aes_256_sha

A message "Certificate is not trusted because it hasn't been verified by a recognized authority using a secure signature" may appear during connection, this is because
BlueMind's SSL certificate is self-signed. Confirm that you want to use this certificate despite this warning.

Plugin fix
Install the following add-on which disables DHE keys https://addons.mozilla.org/en-US/firefox/addon/disable-dhe/

MOBILITY
When I try to create an account I get the message "Incorrect
username or password"
The server and user information entered is correct, and yet this message appears: this means that your administrator has not authorized connection to external devices.
To fix this there are two options:
1. the global administrator can authorize synchronizations for the whole domain in the admin console > System management > System configuration > "EAS
server" tab
2. the domain administrator can authorize user-specific synchronizations in the admin console > Directory browser > select the user > "Devices" tab
In order to connect to BlueMind, you need to get help from an administrator.
To find out more, please go to the Administrator's guide > Users or EAS Server Configuration.

I can't see directory contacts
This is because with the Exchange ActiveSync synchronization protocol, only personal address books are synchronized with smartphone contacts. However, addresses
from other address books (Directory, Collected contacts...) can be accessed through the smartphone's search features (contacts, emails...)
For more details, go to the page about your device in the section Synchronizing with mobile phones and tablets.

I can't see one of my secondary calendars or a shared calendar on
my Android mobile phone
Android does not allow viewing several color-coded calendars simultaneously. As a result, only your calendar is shown and operational.
You can enable this feature and couple it to a third-party application: Multiple calendars on smartphones (see known limitations on that page)

CALENDAR
I can't see a calendar that has been shared with me
By default, you are only able to see:
your calendar
domain calendars
To see another calendar, you must subscribe to it:
go to the user settings management section > Calendar > "Subscriptions" tab
look for the calendar you want using the "Add a calendar" text box
select the calendar suggested by autocomplete
confirm by clicking "Save"
For more details, please go to Calendar preferences.

I can only see two colors in the summary even though my
appointment has several tags
For readability reasons, calendar appointments only show two colors at the most.
However, if you hover over it with your mouse, all tags are listed in the tooltip.
For more details go to Tags.

CONTACTS
I can only see two colors in the summary even though my contact
has several tags
For readability reasons, summary contact cards only show two colors at the most.
However, if you hover over it with your mouse, all tags are listed in the tooltip.
For more details go to Les étiquettes (tags).

ADMINISTRATION
I have lost the setup wizard password
You can change the setup wizard password either through the admin console or in command line, even if you do not know the old password. There are two ways of
recovering it:
1. Access the administration console as global administrator admin0 go to System management > System configuration > "Reverse proxy" tab: enter the new
password and save.
2. If you no longer have access to the administration console (after BlueMind upgrade, for example), use command line in console mode:
log into the BlueMind server as root and type the following command:
rm -f /etc/nginx/sw.htpasswd; htpasswd -b -c /etc/nginx/sw.htpasswd admin admin
log into the /setup URL using admin/admin as username and password
This step is necessary even if you have not reached the update step yet.

I have lost the superadministrator admin0 password
From BlueMind 3.5.11 the Admin-CLI client allows you to configure a password without knowing the admin0 password.
Once the tool is installed, type the following command line:
bm-cli user update admin0@global.virt --password "NewPassword"

Scheduled jobs are no longer running
This issue typically occurs after an update during which the bm-setup-wizard package was uninstalled.
To check this, the command below should not return anything:
dpkg -l | grep bm-setup

If the package does not appear, install it.
If the package is present, contact BlueMind support or ask for help on the forum.

The login ID entered for a new user is invalid
New login IDs for new users must comply with the following rules:
Maximum length: 64 characters
Allowed characters are:
lower-case letters from a to z
numbers from 0 to 9
the following special characters: . (full stop), - (hyphen), _ (underscore)
Special characters cannot be placed first

THUNDERBIRD
I want to empty Thunderbird's browser cache
When restarting the connector fails to resolve display issues, in particular if an error is visible in logs, you can reset the cache manually:
in Thunderbird, open the calendar tab
go to Tools > Clear Recent History
select "Everything" in the drop-down menu and check all the boxes
click "Clear now"
close Thunderbird's calendar tab

OUTLOOK
For further investigations and resolving Outlook-related issues, please refer to our dedicated guide Resolving issues with Outlook

I am unable to create a sub-folder in my Inbox
This is due to a server restriction which cannot be configured or modified: the inbox isn't the root folder in the folder hierarchy.
Users can however create as many folders – and subfolders – as they want provided the folders are created at the same level as the inbox rather than as child-folders.

I need to retrieve Outlook logs
Two types of logs can be useful:
BlueMind connector logs, for calendar and contact synchronization issues
IMAP logs, for problems sending and receiving emails

BlueMind Connector Logs
In order to retrieve the appropriate logs, you must first enable advanced logging.
To do this:
Go to advanced options:
Outlook 2007: " Tools/Options" menu > "BlueMind" tab > "Advanced options" button.
Outlook 2010 and above: "File" menu > "BlueMind" tab > "Advanced" button.

Check the "Enable advanced logging" box:

Replay the scenario that triggered the issue.
Once this is done, you can retrieve the logs you need. They are located in the BlueMind folder in your temporary files folder:
Open Windows explorer and enter the following text in the address bar:
%TEMP%\BlueMind

Type <Enter> to confirm.
This takes you straight to the folder.
Logs are located in the file bm-connector-outlook-log.*

IMAP logs
As for the BlueMind connector logs, you must enable advanced logging in order to collect as much information as possible.
To do this:
Outlook 2007:
Go to the "Tools" menu > "Options" > "Other" tab > Advanced options
Check the "Enable logging (troubleshooting)" box
Quit and restart Outlook
Outlook 2010 and above:
Go to File > Options > Advanced options
In "Other", check the "Enable troubleshooting logging (requires restarting Outlook)" box
Exit and restart Outlook.
Next, regardless of the Outlook version you are using:
Rerun the scenario that triggers the issue
Exit Outlook to make sure that all the data is written to the log file
Once this is done, you can retrieve the logs in your temporary logging folder:
Open Windows explorer and type the text below in the address bar:
%TEMP%\Outlook Logging

Type <Enter> to confirm
This takes you straight to the folder concerned.
The files you might want to retrieve are:
the SMTP log folder, for outgoing messages: emailaddress-Outgoing-date-time.log
the IMAP log file, for incoming messages: IMAP-emailaddress-Incoming-date-time.log
To find out more about Outlook logging and logging files: https://support.office.com/en-us/article/What-is-the-Enable-logging-troubleshooting-option-0fdc446d-d1d442c7-bd73-74ffd4034af5?fromAR=1&omkt=en-US&ui=en-US&rs=en-US&ad=US

Where can I find which version of the connector is installed on my
machine?
To find out which version of the connector installed on your machine, hover on the BlueMind synchronization logo in Outlook with your mouse (don't click): a tooltip
showing the connector version is displayed:

